Enrutamiento basado en calidad – OpenSIPs 3.1 – Modulo QROUTING

Una de las cosas más requeridas por todos aquellos que se mueven en el mundo de la venta de llamadas, es un sistema, programa que en base a la calidad de las llamadas permita escoger la mejor ruta disponible en ese momento.

Hay programas de monitoreo de la calidad de las llamadas que pero se limitan solamente a monitorear, no actúan. Entre ellos:

  • Homer SIP Capture Server

  • VoipMonitor

PJSIP type=transport allow_reload=yes

En el archivo de configuración del canal PJSIP, pjsip.conf, en un bloque de tipo trasporte hay un parámetro que define si cada vez que se recarga la configuración del chan_pjsip con el comando:

CLI> pjsip reload

se recargará también la configuración del bloque de tipo trasporte; este parámetro es allow_reload cuyo valor puede ser:

  • no – al recargar la configuración de canal PJSIP los valores contenidos en el bloque de tipo transporte no se actualizarán

Omnileads – Programa GPLv3 para Call Center basado en WebRTC

Ya conocía este proyecto argentino pero esperé hasta hoy para publicar un articulo dedicado. Este Software con licencia GPLv3 permite configurar un Contact Center con campañas entrantes y salientes y con agentes que trabajan utilizando, de manera predefinida, WebRTC. Esto permite que desde su pagina web, los agentes tengan a disposición todas las herramientas necesarias para su trabajo sin tener que apoyarse a dispositivos externos.

Curso OpenSIPs Cluster – Primera edición

Después de anunciarlo desde hace tiempo, por fin está listo y disponible el nuevo curso, organizado por VozToVoice, dedicado a OpenSIPs Cluster. El objetivo de este curso es presentar y explicar esta nueva funcionalidad de OpenSIPs que permite trabajar con distintos servidores OpenSIPs configurados en un mismo Cluster. Esto permite, por ejemplo, tener usuarios registrados en 2 o más OpenSIPs distribuidos geográficamente y ser alcanzables desde cualquier Proxy SIP. El sistema Cluster permite además compartir el estado de los usuario entre 2 o más servidores OpenSIPs.

OpenSSL, desde la versión 1.1.1, soporta mínimo TLS v1.2 – Asterisk PJSIP

Desde la versión 1.1.1, OpenSSL soporta mínimo la versión 1.2 de TLS. Esto quiere decir que si en un cliente se intenta utilizar una versión más antigua, tipo 1.0 o 1.1, muy probablemente veremos este error:

SSL routines-tls_early_post_process_client_hello-unsupported protocol

Esta versión está presente en Debian Buster (10) pero no en CentOS 7 pues lo que sigue les va a interesar solamente si compilaron Asterisk PBX en debian 10 o Raspian 10 (no se las demás distribuciones de Linux que versión de OpenSSL utilizan).

Pages