RTPEngine

OpenSIPs 3.1 y la captura de los tonos DTMF

La verdad es que la versión 3.1 de OpenSIPs trae muchas novedades que espero poder ilustrar en una serie de artículos que voy a publicar a partir de hoy. Cabe destacar que esa versión será la próxima con soporte a largo plazo, la ultima fue la 2.4, pues es una buena idea empezar a tenerla en cuenta ya que está en versión beta y pronto será liberada la primera versión oficial.

En este articulo hablaremos de los tonos DTMF y de como se podrán utilizar en OpenSIPs para controlar las llamadas; algunos ejemplos:

Curso a distancia Proxy SIP Kamailio Avanzado - Quinta Edición

Después de un merecido descanso (digo yo), retomamos los temas queridos por este sitio. Empezamos con una nueva edición del curso dedicado al Proxy SIP Kamailio. En esta nueva edición abordaremos algunos nuevos temas y ampliaremos algunos ya presentes en las ediciones anteriores:

RTPEngine y el Codec G729

En mi penúltima entrada hablaba de algunos cambios que había que realizar para la correcta compilación e instalación de RTPEngine. Vuelvo a escribir sobre el tema porque me acabo de enterar que cambió completamente la forma de compilar el codec G729 proveído por Belledonne Communications:

Antes los pasos a seguir eran:

yum install libtool automake autoconf -y

cd /usr/src

Curso a distancia Proxy SIP Kamailio Avanzado - Cuarta Edición

Después de casi un año desde la ultima edición del curso avanzado del Proxy SIP Kamailio y debido a las muchas solicitudes recibidas, el próximo mes de Octubre tendrá lugar la cuarta edición del curso. En este curso además de la configuración básica (tipo PBX) de Kamailio, se abordarán distintos tipos de escenarios relacionados con la distribución de solicitudes SIP y balanceamiento de Carga. Esto quiere decir que se verá como implementar Kamailio como uno SWITCH de Clase 5 (PBX) y como SWITCH de clase 4 (Conexión con otros servidores, balanceamiento de carga);

[SOLVED] Ultima Versión de RTPEngine en CentOS 7

La ultimas versiones de RTPEngine no compilan correctamente en CentOS 7 debido a un error producido por la versión instalada del lenguaje de programación Perl (5.16.3). Para que el Media Proxy se compile correctamente se necesita la versión de Perl 5.22 o superior.

perl -v

This is perl 5, version 16, subversion 3 (v5.16.3) built for x86_64-linux-thread-multi

(with 39 registered patches, see perl -V for more detail)

Pages