Error al instalar dadhi-linux

user warning: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'INNER JOIN node_access na ON na.nid = node.nid WHERE (na.grant_view >= 1 AND ((n' at line 8 query: SELECT DISTINCT (((1 * (MATCH(node_revisions.title) AGAINST('Error al instalar dadhi-linux Amigos: Este error me aparece al intentar instalar asterisk, al momento de ejecutar make dentro del directorio \" dahdi\" si me orientan un poco por favor ______________________________________________________________________________ Algunos datos extra: Sistema operativo : Centos release 5.8 uname -r = 2.6.18-308.8.2.el5 uname -i = i386 uname -a = Linux ivr02 2.6.18-308.8.2.el5 #1 SMP Tue Jun 12 09:57:26 EDT 2012 i686 i686 i386 GNU/Linux ______________________________________________________________________________ ________________________________ este es el error _________________________________ [root@ivr02 dahdi-linux-2.3.0]# make make -C drivers/dahdi/firmware firmware-loaders make[1]: se ingresa al directorio `/usr/src/dahdi-linux-2.3.0/drivers/dahdi/firmware\' make[1]: se sale del directorio `/usr/src/dahdi-linux-2.3.0/drivers/dahdi/firmware\' make -C /lib/modules/2.6.18-308.8.2.el5/build SUBDIRS=/usr/src/dahdi-linux-2.3.0/drivers/dahdi DAHDI_INCLUDE=/usr/src/dahdi-linux-2.3.0/include DAHDI_MODULES_EXTRA=\" \" HOTPLUG_FIRMWARE=yes modules DAHDI_BUILD_ALL=m make[1]: se ingresa al directorio `/usr/src/kernels/2.6.18-308.8.2.el5-i686\' CC [M] /usr/src/dahdi-linux-2.3.0/drivers/dahdi/xpp/card_bri.o In file included from /usr/src/dahdi-linux-2.3.0/drivers/dahdi/xpp/xpd.h:31, from /usr/src/dahdi-linux-2.3.0/drivers/dahdi/xpp/card_bri.c:29: include/linux/device.h:407: error: expected identifier or ‘(’ before ‘const’ make[3]: *** [/usr/src/dahdi-linux-2.3.0/drivers/dahdi/xpp/card_bri.o] Error 1 make[2]: *** [/usr/src/dahdi-linux-2.3.0/drivers/dahdi/xpp] Error 2 make[1]: *** [_module_/usr/src/dahdi-linux-2.3.0/drivers/dahdi] Error 2 make[1]: se sale del directorio `/usr/src/kernels/2.6.18-308.8.2.el5-i686\' make: *** [modules] Error 2'))) + (1 * (MATCH(node_revisions.body) AGAINST('Error al instalar dadhi-linux Amigos: Este error me aparece al intentar instalar asterisk, al momento de ejecutar make dentro del directorio \" dahdi\" si me orientan un poco por favor ______________________________________________________________________________ Algunos datos extra: Sistema operativo : Centos release 5.8 uname -r = 2.6.18-308.8.2.el5 uname -i = i386 uname -a = Linux ivr02 2.6.18-308.8.2.el5 #1 SMP Tue Jun 12 09:57:26 EDT 2012 i686 i686 i386 GNU/Linux ______________________________________________________________________________ ________________________________ este es el error _________________________________ [root@ivr02 dahdi-linux-2.3.0]# make make -C drivers/dahdi/firmware firmware-loaders make[1]: se ingresa al directorio `/usr/src/dahdi-linux-2.3.0/drivers/dahdi/firmware\' make[1]: se sale del directorio `/usr/src/dahdi-linux-2.3.0/drivers/dahdi/firmware\' make -C /lib/modules/2.6.18-308.8.2.el5/build SUBDIRS=/usr/src/dahdi-linux-2.3.0/drivers/dahdi DAHDI_INCLUDE=/usr/src/dahdi-linux-2.3.0/include DAHDI_MODULES_EXTRA=\" \" HOTPLUG_FIRMWARE=yes modules DAHDI_BUILD_ALL=m make[1]: se ingresa al directorio `/usr/src/kernels/2.6.18-308.8.2.el5-i686\' CC [M] /usr/src/dahdi-linux-2.3.0/drivers/dahdi/xpp/card_bri.o In file included from /usr/src/dahdi-linux-2.3.0/drivers/dahdi/xpp/xpd.h:31, from /usr/src/dahdi-linux-2.3.0/drivers/dahdi/xpp/card_bri.c:29: include/linux/device.h:407: error: expected identifier or ‘(’ before ‘const’ make[3]: *** [/usr/src/dahdi-linux-2.3.0/drivers/dahdi/xpp/card_bri.o] Error 1 make[2]: *** [/usr/src/dahdi-linux-2.3.0/drivers/dahdi/xpp] Error 2 make[1]: *** [_module_/usr/src/dahdi-linux-2.3.0/drivers/dahdi] Error 2 make[1]: se sale del directorio `/usr/src/kernels/2.6.18-308.8.2.el5-i686\' make: *** [modules] Error 2')))) / 2) AS score, node.title AS node_title, node.nid AS nid, node.language AS node_language FROM node node LEFT JOIN node_revisions node_revisions ON node.vid = node_revisions.vid WHERE (node.status = 1) AND (node_revisions.nid <> 551) INNER JOIN node_access na ON na.nid = node.nid WHERE (na.grant_view >= 1 AND ((na.gid = 0 AND na.realm = 'all') OR (na.gid = 0 AND na.realm = 'content_access_author') OR (na.gid = 1 AND na.realm = 'content_access_rid'))) GROUP BY score, node_title, nid, node_language HAVING score > (1) ORDER BY score DESC LIMIT 0, 8 in /home/voztovoice/public_html/modules/views/plugins/views_plugin_query_default.inc on line 1150.
Versión para impresiónSend by email

Amigos:
Este error me aparece al intentar instalar asterisk, al momento de ejecutar make dentro del directorio " dahdi"
si me orientan un poco por favor

______________________________________________________________________________
Algunos datos extra:

Sistema operativo : Centos release 5.8
uname -r = 2.6.18-308.8.2.el5
uname -i = i386
uname -a = Linux ivr02 2.6.18-308.8.2.el5 #1 SMP Tue Jun 12 09:57:26 EDT 2012 i686 i686 i386 GNU/Linux
______________________________________________________________________________

________________________________
este es el error
_________________________________

[root@ivr02 dahdi-linux-2.3.0]# make
make -C drivers/dahdi/firmware firmware-loaders
make[1]: se ingresa al directorio `/usr/src/dahdi-linux-2.3.0/drivers/dahdi/firmware'
make[1]: se sale del directorio `/usr/src/dahdi-linux-2.3.0/drivers/dahdi/firmware'
make -C /lib/modules/2.6.18-308.8.2.el5/build SUBDIRS=/usr/src/dahdi-linux-2.3.0/drivers/dahdi DAHDI_INCLUDE=/usr/src/dahdi-linux-2.3.0/include DAHDI_MODULES_EXTRA=" " HOTPLUG_FIRMWARE=yes modules DAHDI_BUILD_ALL=m
make[1]: se ingresa al directorio `/usr/src/kernels/2.6.18-308.8.2.el5-i686'

CC [M] /usr/src/dahdi-linux-2.3.0/drivers/dahdi/xpp/card_bri.o
In file included from /usr/src/dahdi-linux-2.3.0/drivers/dahdi/xpp/xpd.h:31,
from /usr/src/dahdi-linux-2.3.0/drivers/dahdi/xpp/card_bri.c:29:
include/linux/device.h:407: error: expected identifier or ‘(’ before ‘const’
make[3]: *** [/usr/src/dahdi-linux-2.3.0/drivers/dahdi/xpp/card_bri.o] Error 1
make[2]: *** [/usr/src/dahdi-linux-2.3.0/drivers/dahdi/xpp] Error 2
make[1]: *** [_module_/usr/src/dahdi-linux-2.3.0/drivers/dahdi] Error 2
make[1]: se sale del directorio `/usr/src/kernels/2.6.18-308.8.2.el5-i686'
make: *** [modules] Error 2

Enviar un comentario nuevo

El contenido de este campo se mantiene privado y no se mostrará públicamente.
  • Las direcciones de las páginas web y las de correo se convierten en enlaces automáticamente.
  • Saltos automáticos de líneas y de párrafos.
  • Puede publicar código usando las etiquetas: <code>...</code> (genérico) o <?php ... ?> (PHP subrayado).
  • Insertar una macro de Google Maps

Más información sobre opciones de formato

CAPTCHA
Esta pregunta es para averiguar si eres un humano (aunque troll) o una maquina
CAPTCHA de imagen
Introduzca los caracteres mostrados en la imagen.
To prevent automated spam submissions leave this field empty.
Distribuir contenido Distribuir contenido