OpenSSL

OpenSSL, desde la versión 1.1.1, soporta mínimo TLS v1.2 – Asterisk PJSIP

Etiquetas: 

Desde la versión 1.1.1, OpenSSL soporta mínimo la versión 1.2 de TLS. Esto quiere decir que si en un cliente se intenta utilizar una versión más antigua, tipo 1.0 o 1.1, muy probablemente veremos este error:

SSL routines-tls_early_post_process_client_hello-unsupported protocol

Esta versión está presente en Debian Buster (10) pero no en CentOS 7 pues lo que sigue les va a interesar solamente si compilaron Asterisk PBX en debian 10 o Raspian 10 (no se las demás distribuciones de Linux que versión de OpenSSL utilizan).

Subscribe to RSS - OpenSSL Subscribe to VozToVoice - All comments