Librería WolfSSL llega a la versión 5.4.0 y se puede integrar con la versión 3.2 de OpenSIPs

La librería WolfSSL de que se ha hablado en este blog hace unos meses, llega a la versión 5.4.0 con la gran novedad del soporte del protocolo DTLS versión 1.3 (Protocolo de Seguridad de Capa de Transporte) utilizado para cifrar el flujo media cuando se utilice WebRTC.

Desde la versión 3.2 de OpenSIPs es posible decidir si utilizar la librería OpenSSL o la librería WolfSSL para la gestión del cifrado de la señalización SIP. Su instalación es bastante sencilla:

cd /usr/src

git clone https://github.com/OpenSIPS/opensips.git -b 3.2 opensips_3_2 --recursive

cd opensips_3_2

make menuconfig

donde se selecciona la librería para que se compile en Configure Compile Option → Configure Excluded Modules:


de esta forma se compilarán la dos librerías y el modulo para la gestión de los certificados y configuración del protocolo TLS en OpenSIPs. No olvidemos que WolfSSL soporta el protocolo TLS versión 1.3 desde hace rato, considerado, por el momento, el más seguro a utilizar aunque la versión 1.2 todavía es solida. NO UTILIZAR VERSIONES ANTERIORES EN SU SERVIDORES EN PRODUCCIÓN

Por ahora es todo. Me comentan

 

Vota el Articulo: 

No votes yet
Evalúa la calidad del articulo
Subscribe to Comments for "Librería WolfSSL llega a la versión 5.4.0 y se puede integrar con la versión 3.2 de OpenSIPs" Subscribe to VozToVoice - All comments