Elastix Problema Con mi Servidor Local Ayuda Pless

Bueno les comento lo que tengo para que se den una idea....

Resulta que tengo una red local de 3 pc en cual en 1 de ellas tengo instalado Elastix 1.5.2-2 para realizar pruebas en red local

El Sofphone que utilizo es X-lite

He podido configurar IVR, Creacion de Extenciones y todo esto anda genial las extennciones por ej 100 y 101 que tengo creadas se pueden llamar entre si, mandar video llamada todo genial dentro de la red local.

El problema se vio cuando yo atraves de internet desde otra pc logeo a mi servidor local que obio tiene salida a internet y ya lo he probado administrar al elastix desde otro lugar por internet y funciona  lo que me esta dando problema es lo siguiente
Cuando logeo x-lite desde otra pc y en el Domain pongo ej "pruebaserver.com" que es el tengo creado por no ip funciona logea de hecho puedo llamar desde ese lugar a mi casa las pc q estan en red pero el problema es que cuando llamo me esuchan y todo pero yo no los esucho a ellos no se por q en red local funciona bien pero atraves de internet uno me escuchan bien pero yo no los esucho me gustaria que me ayudaran muchas gracias

VozToVoice: 

Problema de NAT

Este no es un sitio dedicado a Elastix. Aquí normalmente solo se habla de Asterisk "duro y puro" :); de todas formas te voy a contestar.

Cuando no hay problemas de audio siempre está relacionado con el NAT, es decir con problemas de enrutamiento de los paquetes audio.

Para que tu elastix sea "visible" en Internet debes tener abiertos unos cuantos puertos en tu router y/o cortafuegos.

Considera que si usas el protocolo SIP debes tener abiertos por lo menos estos puertos:

5060 UDP para la senalizacion SIP
10000-20000 para la parte audio/vídeo (dependiendo de la configuración de tu elastix) protocolo RTP (Real Time Protocol)

Luego en la configuración de las extensiones que están afuera de tu red local tienes que poner el siguiente parámetro:
NAT=yes

Cuéntanos como te fue
Chao

Antes que nada Pido disculpas

Antes que nada Pido disculpas por haber posteado sobre elastix pero agradesco de ayudarme de = forma.

Mira te cuento mejor dicho te muestro lo q hice para q veas haber q tal.

Free Image Hosting at www.ImageShack.us

QuickPost Quickpost this image to Myspace, Digg, Facebook, and others!

esto son los puerto que tengo abierto q es la parte de virtual port para decile q mi ip publica que me da adsl la mande ahi q segun lei eso son los puertos y eso me esta funcionando es decir se pueden conectar pc desde afuera gracias a ellos
despues aca habri los puertos que me diguistes

Free Image Hosting at www.ImageShack.us

QuickPost Quickpost this image to Myspace, Digg, Facebook, and others!

Aca esta la parte del nat que me diguistes lo puse en YES

Free Image Hosting at www.ImageShack.us

QuickPost Quickpost this image to Myspace, Digg, Facebook, and others!

y por ultimo cuado abri el puerto que me diguistes "5060 UDP para la senalizacion SIP" no se conectaba y me salia en el sofphone timpo de espera agotado cuando le saco ese puerto al router conecta pero bueno pasa que yo no los esucho y ellos si

Free Image Hosting at www.ImageShack.us

QuickPost Quickpost this image to Myspace, Digg, Facebook, and others!

Elastix y nat

Lo siento mucho pero no teniendo tu servidor elastix a la mano no puedo ayudarte mucho.

El NAT=yes no va configurado en la parte general del sip.conf sino en la configuración de cada extensión/interno. Esto porque no todos tus teléfonos están detrás de un NAT (los de la red local no tienen ese tipo de problema).

No se si estas configurando bien tu router pero hasta donde yo sepa no es en trigger port que tienes que abrir los puertos sino en virtual server

Creo que deberías pedir ayuda a algún amigo real que pueda meterle mano a tu router para configurarlo bien.

Saludos

si es por el acceso al Router

si es por el acceso al Router y a elastix yo te paso mi msn y te paso un usuario para administrar elastix y vichas total es de prueba en una pc local y te paso tambien una ip para q acedas al router a mirar si te animas te paso el mail taria genial

registros fuera de mi lan

Que tal mira estoy empezando con asterisk puro, y el tema es que estoy preparando uno para reemplazar un trixbox, que no me ha convencido, pero tengo un inconveniente con el registtro fuera de mi lan, ya hize los cambios sugeridos y tambien el nateo en mi router y ya puedo registrar mi softphone fuera de mi lan y escucho y se escucha pero con otro anexos en otros lugares no puedo hacerlo, alguno se registra brevemente y luego cae en unrecheable, pero en trixbox si logran mantenerse registrados de forma mas estable, falta algo que hacer en los archivos uso asterisk 1.6.2

Re: registros fuera de mi Lan

Hola Eduardo,

me parece bastante raro que algunos pierdan la conexión.

El unico modo para saber de que depende es trazar la puerta 5060 para ver que pasa.

Si la extension que pierde la registración es por ejemplo la 1000, desde la consola de asterisk:

CLI> sip set debug peer 1000

luego pegas el resultado qui o en un archivo de texto.

Saludos

quisiera saber cual fue la

quisiera saber cual fue la solucion ya que yo tengo los mismos problemas que el que contacto con elastix y ya redireccione todos los puertos mencionados en udp y tcp

si pudieran dar la solcuion o cual puede ser el problema

buen dia quisier saber si hay

buen dia quisier saber si hay alguna solucion para este problema... pues realmente me escuchan pero yo no escucho... y tengo la config del telefono en NAT=yes... pero no funciona...

por su ayuda muchas gracias

Solucion

Tu problema se debe a 2 cosas, primero el NAT, deberias poner la ip interna de tu server en la zona DMZ de tu router(desmilitarized zone) solo para pruebas porque es una configuracion peligrosa ya que en esta zona el firewall no funciona, es decir dejas todos los puertos abiertos. Segundo, si al estar en DMZ tu problema continua, entonces se debe a tu ancho de banda de subida, supongo que en la red del server estas usando una conexion ADSL por lo tanto tu ancho de banda de subida no debe pasar los 512 kb en total y si estas usando software P2P en alguna de las maquinas te quedas sin ancho de banda. Haz pruebas y me avisas... suerte.

lo que tienes que hacer es

lo que tienes que hacer es port forward los puertos a tu elastix  y configurar el archivo sip_nat.conf

externip=tu ip ext

nat=yes

externrefresh = 5

localnet = 192.168.10.0/255.255.255.0

 

 

Gracias por todos los comentarios

De igaual forma , estoy aprediendo a instalar Asterisk Puro .
Quisera saber que tal anda en Lubuntu version 12 o 15. >Pregunto esto porque de todos los distros linux que he prbadoel Lubuntu es el que mejor corre en mi modesta maquinita. AMD 2 , 2.1 ghz con 1 mega de ram.

Como seria el procediemiento.

saludos

Ricardo Ugalde

Las llamadas locales no funcionan

Su llamada no se puede realizar tal como la ha marcado, por favor compruebe el numero y llame nuevamente

Subscribe to Comments for "Elastix Problema Con mi Servidor Local Ayuda Pless" Subscribe to VozToVoice - All comments