Unable to connect to remote asterisk (does /var/run/asterisk.ctl exist?)

Versión para impresiónSend by email

Revisando las claves de búsqueda con las cuales bastantes usuarios de Internet llegan a visitar mi sitio web, me enteré que muchos ponen en el buscador la frase que aparece en el titulo de este post.

Me imagino que la mayoría de ellos tienen problema al arrancar Asterisk o, en segunda instancia, tienen algún error de configuración que no les permite a la centralita arrancar.

Pues espero ayudarlos con mi pequeña experiencia.

Cuando, en su entonces, jugaba con FreePBX me había pasado algo parecido hasta que encontré esta guía que para mi es la mejor para instalar asterisk con FreePBX en Centos (en ingles). Les aconsejo usarla porque es muy bien hecha y a mi me funcionó todo en seguida.

Otro error que normalmente se hace es intentar arrancar la consola de asterisk si haber arrancado el servidor. La solución es muy simple:

/etc/init.d/asterisk start

y luego entrar a la consola

asterisk -rvvvvvvvvvvvv

Si esto tampoco funciona, puede ser que haya algún tipo de conflicto entre los módulos instalados.

Una buena solución es mirar los registros de la centralita.

En la distribución Centos estos e encuentran en /var/log/asterisk

El archivo más importante es full

Abrenlo con el editor nano

nano /var/log/asterisk/full

y miren todas las líneas que tienen un ERROR. Ej.

[Dec  1 10:24:49] ERROR[2685] res_jabber.c: JABBER ERROR: No Connection
[Dec  1 10:24:53] ERROR[2685] res_jabber.c: JABBER ERROR: No Connection
[Dec  1 10:24:57] ERROR[2685] res_jabber.c: JABBER ERROR: No Connection
[Dec  1 10:25:01] ERROR[2685] res_jabber.c: JABBER ERROR: No Connection

Una vez que sepan que tipo de error le sale arrancando asterisk pueden tomar las justas medidas para resolverlo.

Si necesitan quitar algún modulo que les está creando problemas, pueden hacerlo (siempre y cuando no sea determinante para que la centralita funcione) modificando este archivo:

nano /etc/asterisk/modules.conf

y añadir una línea tipo:

noload => res_config_ldap.so

Guardan el archivo y intentan arrancar nuevamente Asterisk.

Echen una miradita al archivo

nano /etc/asterisk/asterisk.conf

y averiguen que todas las carpetas de configuración definidas en él sean exactas.

Si esta pequeña guía les ha sido efectiva me gustaría saberlo.

Un saludo

 

Technorati Tag: ,,

Comentarios

Unable to connect to remote asterisk does /var/run/asterisk.ctl

Estimados: Les comento que tengo una tarjeta X100P, la verdad es que causa bastantes problemas con placas madres nuevas (sobre todo las foxconn que andan saboteando Linux), dentro de todos los problemas para habilitar asterisk me ha salido este problema, entre todas las pruebas que hice la unica que me levanto los servicios dahdi y asterisk sin problemas fue eliminarlos del inicio (chkconfig --levels 3 dahdi stop ; chkconfig --levels asterisk stop) y agregar en el rc.local lo siguiente
safe_asterisk
service dahdi start
service asterisk reload

Espero les sirva

Gracias

Muchísimas gracias por tu aporte.

Un saludo

Un dato extra

Me sirvió mucho tu post. En mi caso, instalé la CLI de Asterisk en Ubuntu 8.10 usando apt-get. No tenia el servidor ejecutando, asi que lo inicié con el comando que mencionaste, pero al intentar ejecutar el cliente con:

asterisk -rvvvvvvvvvvvv

Me marcaba esto:

== Parsing '/etc/asterisk/asterisk.conf': Not found (Permission denied)
== Parsing '/etc/asterisk/extconfig.conf': Not found (Permission denied)
Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)

Era un problema de permisos. Asi que ejecuté el comando de nueva cuenta usando sudo:

sudo asterisk -rvvvvvvvvvvvv

Y asunto resuelto:

== Parsing '/etc/asterisk/asterisk.conf': Found
== Parsing '/etc/asterisk/extconfig.conf': Found
Connected to Asterisk 1.4.21.2~dfsg-1ubuntu3 currently running on control01-desktop (pid = 5138)
Verbosity was 0 and is now 12
control01-desktop*CLI>

Muchas gracias por tu post de nueva cuenta.

Problema de permisos?

¿cómo solucionaste el tema de permisos?

Solucion Boot Startup Amportal/Asterisk ...

Hola, estuve con el mismo problema, primero:
(recuerda siempre loggearte como SU)
#reboot

cuando cargue de cero, en esta secuencia:
#amportal start
#asterisk

luego podrás cargar la consola CLI con
#asterisk -r

el problema es que hay que hacerlo cada vez que reinicias la máquina, lo cual es un problema.
La solucion:

#nano /etc/rc.local

y antes de exit 0 pones:
sudo amportal start
sudo asterisk

(ctrl + y, enter, enter)

#reboot

y cuando botee verás que tendrá todo listo, ah! prueba con:
#asterisk -r

:-)
mi correo icarrasco@solide.cl por si no te funciona, aunque por la fecha no creo que sigas con el mismo problema jejeje...

saludos,
ICQ

Saludos, soy nuevo en esto de

Saludos, soy nuevo en esto de asterisk,  y también me encontré con este problema, quizas una solución más general pueda ser la siguiente:  ejecutar el comando # asterisk -cvvvvvv, el mismo nos dirá que sucede con nuestro sistema, en mi caso encontré lo siguiente:

.

.

.

.

    -- Registered indication country 've'
    -- Registered indication country 'za'
    -- Setting default indication country to 'us'
  == Parsing '/etc/asterisk/features.conf':   == Found
  == Registered Feature 'testfeature'
  == Mapping Feature 'testfeature' to app 'Playback(tt-monkeys)' with code '99'
Violación de segmento

lo cual me hizo recordar que tenia un archivo llamado features.conf en /etc/asterisk, que había configurado, siguiendo unos pasos de una guía que me hicieron llegar, en fin, lo que hize fué comentar todo lo que tenía este archivo y funcionó.

Este error se puede producir por distintas razones y quizas al correr el comando mencionado anteriormente les pueda indicar cual pueda ser la causa. Esta solución la encontré en el siguiente blog: http://danielbaggio.blogspot.com/2006/08/problems-running-asterisk.html

Saludos

Gracias

Muchas gracias, me funciono a la perfeccion. un saludo

error

Hola estoy configurando un servidor asterisk y antes me conectaba con la consola de asterisk, pero nose que paso, despues me sale siempre el error
root@AsteriskP:/usr/src/asterisk-1.8.20.1# asterisk start
root@AsteriskP:/usr/src/asterisk-1.8.20.1# asterisk -r
Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)

ya he intentado todo, asterisk -vvvvvc, volvi y configure el servidor varias veces, también
borrando los archivos y directorios como (/var/run/asterisk ) , modifiqué el contenido de nano /etc/rc.local, le di sudo asterisk -rvvvvvvvvvvvv pensando que eran permisos, en fin he tratado con muchas cosas pero nose...

alguien tiene otra solución ... gracias

Re: error

Hola,

si estás instalado Asterisk en un servidor virtual, en algunos casos se presenta este problema.

para solucionarlo, en lugar de utilizar el comando: ./configure utilizar:

./configure CC="gcc -O3" CFLAGS=-O3

Me cuentas.

Saludos

does /var/run/asterisk.ctl exist?

Me ha dado este fallo y con la solución que has dado todo solucionado (/etc/init.d/asterisk start
y luego entrar a la consola
asterisk -rvvvvv)

Muchas gracias de verdad!

Distribuir contenido Distribuir contenido